elasticsearch安装(Elasticsearch安装以及配置hanlp中文分词插件)

本文目录
- Elasticsearch安装以及配置hanlp中文分词插件
- Elasticsearch7.14.0安装,配置密码认证及创建用户
- CentOS7 安装 ElasticSearch6.5.4
- centos安装es环境
- Windows 上 怎么安装 install elasticsearch plugin
- elasticsearch8集群安装部署使用
- Elasticsearch 单点模式安装步骤
- LInux下Elasticsearch可视化工具-Kibana的安装
- elasticsearch8安装使用
- elasticsearch安装后出现闪退的问题
Elasticsearch安装以及配置hanlp中文分词插件
elasticsearch默认开启两个端口:9200,用于ES节点和外部通讯;9300,用于ES节点之间通讯
报错: org.elasticsearch.bootstrap.StartupException: java.lang.RuntimeException: can not run elasticsearch as root ,不能以root用户的身份运行elasticsearch
解决方法:新建用户组和用户,并赋予其elasticsearch文件夹的权限
再次运行
WARN: java.lang.UnsupportedOperationException: seccomp unavailable: CONFIG_SECCOMP not compiled into kernel, CONFIG_SECCOMP and CONFIG_SECCOMP_FILTER are needed ,使用新的linux版本即可,不影响使用
启动失败,出现上面四个错误,一一解决
ERROR:无法创建本地文件问题,用户最大可创建文件数太小
解决方法:切换到root用户,limits.conf配置文件
ERROR:无法创建本地线程问题,用户最大可创建线程数太小
解决方法:切换到root用户,进入limits.d目录下,修改90-nproc.conf 配置文件
ERROR:最大虚拟内存太小
解决方法:切换到root用户下,修改配置文件sysctl.conf
ERROR:这是在因为Centos6不支持SecComp,而ES5.2.0默认bootstrap.system_call_filter为true进行检测,所以导致检测失败,失败后直接导致ES不能启动
解决方法:在elasticsearch.yml中配置bootstrap.system_call_filter为false
解决完成后,重新启动,启动成功
如果要在后台运行,使用 ./bin/elasticsearch -d 启动
***隐藏网址***
现在启动elasticsearch,提示jar包冲突
现在启动elasticsearch,没有异常,我们测试一下hanlp分词插件有没有生效
***隐藏网址***
elasticsearch报错并且退出运行
看上去是权限的问题,这就用到hanlp目录下的 plugin-security.policy 文件,修改 /elasticsearch/config/jvm.options 文件,在末尾添加
继续测试上面的链接,提示找不到hanlp.properties,hanlp无法加载词典,elasticsearch退出运行,解决方法:修改 /elasticsearch/bin/elasticsearch.in.sh 文件,将ES_CLASSPATH修改为:
继续测试上面的链接,访问成功,返回结果
可以看到分词效果比较好,而且停用词也被过滤了,大功告成!
Elasticsearch7.14.0安装,配置密码认证及创建用户
此时我们执行文件运行
解决方案:创建一个es用户组以及用户,然后使用es用户启动elasticsearch
elasticsearh从7.0开始默认安装了java运行环境,以便在没有安装java运行环境的机器上运行。
通过阅读elasticsearch-env文件大概35行可以知道
如果配置了环境变量ES_JAVA_HOM,则elasticsearh启动时会使用ES_JAVA_HOM作为java路径。
如果配置了环境变量JAVA_HOM,则elasticsearh启动时会使用JAVA_HOM作为java路径。
如果没有配置Java环境,则elasticsearh启动时会使用自带的jdk来运行
解决方案:
一、安装符合条件的jdk并配置JAVA_HOME。
二、安装符合条件的jdk并配置ES_JAVA_HOME
三、使用elasticsearch自带的jdk配置ES_JAVA_HOME,不需要配置PATH
添加一行
将用户切换回es后再次执行
做到这一步,elasticsearch总算是运行起来了
CentOS7 安装 ElasticSearch6.5.4
最近由于项目需要,重新捡起曾经用过的 ElasticSerach 索引引擎。所谓好记性真不如烂笔头儿。
在写文档之后,想送给自己一句话:
ElasticSearch 是基于 Java 开发。所以,底层它依赖 Java 的环境。所以在安装前,我们一定要先安装 Java 。
为什么是 ElastciSearch 6.5.4 ?是因为我们公司项目全部是这个版本。
我们创建了一个 /data/server/elasticserach 目录。下一步就将 elasticsearch 解压到这个目录。以后可以安装多个版本的 elasticsearch
因为 ElasticSearch 是不允许使用 root 账号启动的。
我们创建了一个 esgroup 用户组的账号 esuser 。并将 /data/server/elasticsearch 目录设置为 esuesr 。
启动之前请将当前用户切换到 esuser 用户。否则,会提示不能以 root 启动的错误。
如果在启动过程中报错了。几乎都是权限问题导致的。
***隐藏网址***
由于我们是在服务器安装,所以您想通过外网访问。还需要再进行如下配置:
它们的作用:允许域名访问。
***隐藏网址***
防火墙开放 9200 端口
或者关闭防火墙
systemctl disable firewalld.service 禁止防火墙开机启动
因为我们更改配置。所以,我们要重启 elasticsearch 服务器。
centos安装es环境
rpm -qa |grep java
rpm -qa |grep jdk
rpm -qa |grep gcj
rpm -e
yum install java-1.8.0-openjdk* -y
java -version
***隐藏网址***
tar -zxvf elasticsearch-6.2.4.tar.gz
groupadd es #新建组
useradd es -g es #新建用户
sudo chown es:es /usr/local/elasticsearch-6.2.4
su es #切换用户
vim conf/elasticsearch
path.data: /usr/local/elasticsearch-6.2.4/data
path.logs: /usr/local/elasticsearch-6.2.4/logs
mkdir data
network.host: 0.0.0.0
vim conf/jvm.options
-Xms512m
-Xmx512m
bin/elasticsearch
***隐藏网址***
mv elasticsearch-analysis-ik-6.2.4.zip ./elasticsearch-6.2.4/plugins/
unzip elasticsearch-analysis-ik-6.2.4.zip
rm elasticsearch-analysis-ik-6.2.4.zip
bin/elasticsearch
ERROR: bootstrap checks failed
解决办法:
/etc/security/limits.conf,追加以下内容;
解决办法:
/etc/sysctl.conf,追加以下内容:
vm.max_map_count=655360
保存后,执行:
sysctl -p
systemctl stop firewalld.service
docker exec -it e6c060f721fc nginx -s reload
最大尝试次数
php artisan queue:work --tries=3
Windows 上 怎么安装 install elasticsearch plugin
配置elasticsearch的存储路径为hdfs需要两步,安装插件elasticsearch-hadoop,在联网的情况下在命令窗口运行:plugin -install elasticsearch/elasticsearch-hadoop/1.2.0即可。 如果没有联网解压插件到plugins中即可,目录为/hadoop。。。。。 在配置文件elasticsearch.yml中要配置如下: gateway: type: hdfs gateway: hdfs: uri: hdfs://localhost:9000
elasticsearch8集群安装部署使用
***隐藏网址***
默认 ca 文件名为 elastic-stack-ca.p12 ,同时需要输入 ca 密码 ;
默认证书文件名为 elastic-certificates.p12 ,同时输入证书密码;将此证书文件放到各个节点的目录 config/certs 下
设置通信证书密码为 12345678
需要注意 discovery.seed_hosts 的配置是其他 ES 节点
启动集群后,可使用 ElasticView 查看节点信息
创建一个索引 user-index ,指定2个分片和1个副本,再从 ElasticView 控制台上可直观观察;
可以看到索引有两个主分片,分别在 a 和 b 两台机器,且节点互为副本节点
写入一些测试数据
在此处使用了 RestClient.builder 创建 restClient ,传入了多个 HttpHost ,测试的时候可以尝试将 134 节点关掉,在超时1秒后将连接 136 查询到数据;
Elasticsearch 单点模式安装步骤
以 7.16.1 版本为例
Elasticsearch 不允许以 root 账号运行,要创建一个新账号,比如 es。
后台运行需要加 -d 参数:
启动之后,就可以访问了:
默认情况下,Elasticsearch 不允许远程访问,只能本机访问。要开放远程访问,需要做如下配置:
将 network.host 配置项的值改为 0.0.0.0
保存后启动,发现报错:
可以看到有4条错误提示:
接下来逐个解决上述 4 个问题。
添加以下配置:
添加以下配置:
重新加载配置文件,让配置生效:
添加以下配置项,将运行模式指定为单节点模式,就解决了第4个问题:
如果是docker,则在启动时加上该配置项:
也可以用另一个配置项解决第4个问题:
如果是要构建自己的docker镜像,那么应该在 Dockerfile 中添加如下配置:
解决完这4个问题后,就可以成功启动Elasticsearch了,当然,要开启9200端口,集群模式还要开启9300端口。
LInux下Elasticsearch可视化工具-Kibana的安装
本文安装的ES版本是7.5.0,Kibana版本是7.5.0,版本号最好对应起来,在命令行输入:
2.1 解压
2.2 修改配置文件kibana.yml,文件位置在解压后的文件夹下config下
修改内容,主要是 server.port、server.host、elasticsearch.url、kibana.index。
2.3 启动
***隐藏网址***
打开Dev Tools
3.1 获取所有数据
3.2 新增数据
3.3 查询某条数据
***隐藏网址***
***隐藏网址***
elasticsearch8安装使用
将 elastic 用户的文件数限制调整为65536
使用 sysctl -p 使系统配置生效
首次启动后控制台会打印出一些预设置的log信息,以及会在 elasticsearch.yml 配置文件的的最后面增加 SECURITY 相关配置,可以不用理会,因为需要使用时可用脚本工具去修改默认生成的一些配置信息;
第一次启动完成后会自动生成一些信息,接下来修改一下默认密码
此时是未开启 ssl 的情况下可以正常访问,同时也可以开启 ssl 完成请求
***隐藏网址***
***隐藏网址***
重新打开 ssl 配置
***隐藏网址***
***隐藏网址***
***隐藏网址***
由于直接使用 curl 操作相对较麻烦,临时扩展定义一个 ecurl 别名,如下(后面即可用 ecurl 简化操作)
安装中文分词插件 sudo bin/elasticsearch-plugin install analysis-smartcn ,安装成功后重启 es
比如要将“永远滴神”定义为一个词,需要在配置 IKAnalyzer.cfg.xml 中指定 《entry key="ext_dict"》customer.dic《/entry》 ,然后创建文件 customer.dic ,并添加一行“永远滴神”,重启后再次访问即可看到分词结果
elasticsearch安装后出现闪退的问题
解决问题第一步:
使用Power Shell来看其问题
点击快捷键window 搜索powerShell
进入elasticsearch的bin目录 执行./elasticsearch.bat
出现报错
\Java\jdk1.8.0_131\bin\java.exe "-cp-"
那就是jdk的目录里含有空格
解决方法:将jdk的文件目录放在没有空格目录下面
提示:千万别把elasticsearch放在中文目录下面

更多文章:
androidapp源码免费下载(如何实现APK的反编译得到APK的源码)
2026年9月22日 18:00
service pack 3(操作系统版本升级(SP) Service Pack 3当中的“Service Pack 3”是什么意思)
2026年9月22日 10:20
html代码怎么写大佬教程(html网页的题来个大佬,写代码,题目在图上)
2026年9月22日 10:10
结构体内又一个struct(c++ 在结构体中再嵌入一个结构体如何调用)
2026年9月22日 09:40
cocos creator中文(cocoscreator和cocoscreator3d的区别)
2026年9月22日 02:30






